Upload Logic and Remote Assets [RAZUNA 1.9.5]


#1

Hi all,
I’m a newbie of razuna and i’m trying to learn how it works.
I find it really interesting and usefull but i have some questions :stuck_out_tongue:

I have a razuna 1.9.5 self hosted in ubuntu 16.04 LTS
We use a VPN to connect a remote directory and use it like Tenant’s assets.
(I had set the /nfs/remoteDir/ to respond at /opt/razuna/tomcat/webapps/razuna/assets, and set via WEB Admin GUI the storage location in /opt/razuna/tomcat/webapps/razuna/assets)

If I try to upload a generic file ( i’m encountering this issue with .pdf .doc .img .mov) i see Razuna stores the file in /opt/razuna/tomcat/webapps/razuna/raz2/dam/incoming instead of the directory set via Web.

I know that i’m missing something but i don’t find what.

Thanks
Fabio


#2

Hello,

Changing directories in Razuna requires some knowledge of Tomcat and Networking. It’s a bit cumbersome and overly complicated in my book :slight_smile:

That said, you need to change the path in Razuna backend to the correct directory. Then within Tomcat set the “assets" path. Check this form for the correct syntax. Also, check the permissions of the running Tomcat user with the one you have on the directory. Also, don’t forget to always restart tomcat.

Hope this helps.


#3

Hi Nitai,

Thank you for your answer and sorry if I update my post just now.
I’m encounter some problem with my Razuna Server, if i try to delete file from trash i see that log says

93.42.116.138 - - [19/Jul/2018:14:21:11 +0200] "GET /razuna/assets/2//thumb_48300CE437494DA78BCDEA11A583037C. HTTP/1.1" 404 1126
93.42.116.138 - - [19/Jul/2018:14:21:11 +0200] "GET /razuna/assets/2//thumb_DA4ABAD73475476485BF1CE2B444E2FF. HTTP/1.1" 404 1126

i don’t understand one thing why there is a // after /assets/2?
This could be the reason why it don’t find the file (404 error)

Can you help me?
Thanks
Fabio