The upload of document_name is still in progress!

#1

Hi,
I’m on razuna 1.9 on Ubuntu server 16.04.1 64 bits with Java™ SE Runtime Environment (build 1.8.0_111-b14) installed.
When I upload a document called document_name for instance, I got that message showing in place of preview image : The upload of document_name is still in progress!
I have to do an action that refresh the view to see the preview if it’s an image and have the normal icons (same for text document).
I have nothing revelant in catalina.out. The only error in bluedragon.log is :

05/12/16 14:16.00: Can’t validate connections for h2
05/12/16 14:16.00: Can’t validate connections for h2
05/12/16 14:16.00: Can’t validate connections for h2
This message is repeated several times (got this message if I use h2 db and even if i use mysql db)

According to this post : Upload image 'still in progress'
I have checked the path to imagemagick and exiftool but the problem is still there.

Please any idea what/where to look ?

Trash and Incoming folder not cleaned
#2

Is everything else working? Can you upload images, videos, etc? If not, it
is because of an issue with the Razuna 1.9 distribution.

Please shut down Razuna. go into the webapps/razuna folder and remove the
folder “db”.

This will RESET the default credentials of your Razuna install. however,
just run the firsttime wizard again enter all infos and all your data will
still be there.

#3

Hi,
Upload works fine, I can upload images, videos etc. But each time I upload a file I got the message :

The upload of document_name is still in progress!

I have to refresh the view to get ride of that message (I tried on Chrome, Firefox and Opera, same behavior).

I tried to delete the folder db, rerun the firsttime wizard (by the way, all datas are gone) but still when I upload a file I got the same message.

#4

Hi scivray ,

From our site , we did not see the same issue. But we will look into the issue and reply to you soon.

Thank you.

#5

OK, thank you.

I tried with version 1.9.1 but I got the same issue.
(By the way, in your version 1.9.1, on admin page it shows that we should update to version 1.9.1, it’s a small bug I think, . The ‘logs’ folder is missing and have to be created.)

#6

Wait hold on… everything works and you simply have to refresh the page to get “rid” of this “progress” message?

This is not a bug nor an issue. This is normal, as Razuna could not process all metadata, thumbnails and/or indexing in the backend.

#7

Which “logs” folder is missing? Did Razuna not start without it?

#8

In 1.9.1, the folder razuna_tomcat_1_9_1/tomcat/logs is missing. When starting Tomcat with the script razuna_tomcat_1_9_1/tomcat/bin/startup.sh , got the following error :

Detecting JVM PermGen support…
PermGen switch is supported. Setting to 512m
Using CATALINA_BASE: /opt/razuna_tomcat_1_9_1/tomcat
Using CATALINA_HOME: /opt/razuna_tomcat_1_9_1/tomcat
Using CATALINA_TMPDIR: /opt/razuna_tomcat_1_9_1/tomcat/temp
Using JRE_HOME: /usr/lib/jvm/java-8-oracle
Using CLASSPATH: /opt/razuna_tomcat_1_9_1/tomcat/bin/bootstrap.jar:/opt/razuna_tomcat_1_9_1/tomcat/bin/tomcat-juli.jar
touch: impossible de faire un touch ‘/opt/razuna_tomcat_1_9_1/tomcat/logs/catalina.out’: Aucun fichier ou dossier de ce type
./catalina.sh: 387: ./catalina.sh: cannot create /opt/razuna_tomcat_1_9_1/tomcat/logs/catalina.out: Directory nonexistent

and Tomcat doesn’t start.

#9

Exactly. The upload was running nice in version 1.7 but now a manual refresh is needed.
If I refresh 1 second after upload or 10 minutes after upload I still got the preview.
It seems to me that the refresh, performed automatically after uploading, causes this issue.

#10

Thank you. Fixing it right now for others in the future.

#11

I made a short video to show the issue : https://youtu.be/qIu8p7vdNVU
On the left it’s razuna version 1.7, the ui is refreshed with the preview.
On the right it’s razuna version 1.9.1, the ui isn’t refreshed.

#12

Yes and when you refresh the folder in 1.9 it shows also, right? If not,
then the path to your third library tools is not correct.

#13

Yes. If I refresh I got the preview like I got in version 1.7.

I tried modify the file webapps/razuna/global/host/dam/views/ajaxparts/dsp_folder_content.cfm where the text

“The upload of “#filename#” is still in progress!”

is hard coded by adding a javascript

$(“table.grid tr”).first().find(“div”).first().find(“a”).get(1).click();

that click on the folder name to refresh but I ended in a infinite loop :confused:
It seems that even by adding a sleep before the test

cfif is_available

(to give time to indexing process) but this test is still false right after the upload. I don’t know ColdFusion language, I didn’t succeed to find out the function/file that is calling the folder refresh just after the upload.
Can you please point me to the right file(s)/function(s) that are involved in the upload process ? especially the 2 xhr calls after the upload.
If I can’t correct what is for me a regression I will end up using version 1.7.

Thank you.

#14

Well, then this is correct. The reason, why this is shown is that the process in the backend didn’t finish. Do you rather have a broken image there? I think not. Hence the reason for the text.

#15

I was trying to add a pause, before the ajax call to get the folder content, in order to give some time to the backend process to finish, so the image preview may be show instead of the text.

Nevermind, I’ll go in prod with version 1.7.

Thank you for your time.

Have a nice day.