Suddenly blank page for login? Browser says "ERR_CONTENT_DECODING_FAILED"


#1

Hi,

suddenly Razuna stopped working properly - although just the frontend.
Chrome says “Content encoding error” and “ERR_CONTENT_DECODING_FAILED”
Firefox delivers just one character on login page (looks like an error).

API is working, image delivery working too (nginx as frontend), it’s just impossible to login (either tenant and admin).

catalina.out shows no error -_-

Any ideas?


#2

Some more information:

  • Using MySQL as storage engine - is working well (because external)
  • razuna_backup.trace.db is HUGE and gives these last lines:
    FROM razuna_backup [42102-191]
    2018-01-16 13:37:43 jdbc[3]: exception
    org.h2.jdbc.JdbcSQLException: Table “BACKUP_STATUS” already exists
    Table “BACKUP_STATUS” already exists; SQL statement:
    CREATE TABLE backup_status
    (
    back_id VARCHAR(100),
    back_date timestamp,
    host_id BIGINT
    ) [42101-191]

That’s pretty strange - h2 shouldn’t be used at all!? Any ideas?


#3

Ok, I could get it working again by DISABLING gzip compression in tomcat (server.xml) - but that worked pretty good at all before - without any problems.

Anyone has an idea why it happens?


#4
  1. Backup
    You might have backup turned on in the backend. If you use MySQL, do not use the internal backup tool and use mysqldump scripts.

  2. Tomcat
    I’ve send this before with Java updates. You can simply upgrade Tomcat to the latest edition, that usually fixes it. Razuna works with Tomcat 8.5.


#5

Sorry to pull this up, but I have a question regarding your answer now:

How do I upgrade tomcat manually? I can’t find any docs regarding this issue.

  • Can I simply overwrite the tomcat/ directory?
  • Do I have to take care about overwritten files? Which one? (At least server.xml I guess, maybe setenv.sh as well - anything else?)
  • Any Java upgrades necessary?

#6
  1. Download Tomcat 8.5.x
  2. Move the razuna and razuna-searchserver from the OLD to the new Tomcat
  3. Move setenv.sh, server.xml, and context.xml from the OLD to the new Tomcat (If you are upgrading from v7 to v8 DO NOT move the files, but EDIT them and some libraries have changed)