Success node not found Error while searching


#1

Tryout out the search and it just throws an error in the APP, via API, etc.

Example URL: for search

http://localhost/razuna/global/api2/search.cfc?method=searchassets&api_key=#MYKEY#&searchfor=batman*

this returns:
{“message”:“an invalid request was attempted”,“errorcode”:"",“detail”:""}

Any ideas why it does not like the search? its straight out of the docs


#2

There is not even an errorcode, i.e. doesn’t look like you are hitting the Razuna server. Please check your URL, port, firewall, etc.


#3

Its on the same server. No firewall, part of standard installation.


#4

it has to be hitting the razuna server. its returning formatted JSON. its not just random.


#5

Really no idea. Sorry. Does the search within Razuna work?


#6

no. same message. API or non API.


#7

Ah, then your search server is not configured. Go to the backend admin and check under “Indexing”. Most likely reconfigure the database connection.

At the same time, check your tomcat log (catalina.out). When the search server is configured you will see it in there.


#8

It just gives me a generic message back:

[//discourse-upload-backup.s3.amazonaws.com/original/1X/137f42a16a07f9ecc9a2f515338580cfc346dca9.png]

[//discourse-upload-backup.s3.amazonaws.com/original/1X/97f1057d89d9869d4c1de5fb19281a8217a94045.png]


#9

Hi,
I got an error like yours a while ago when migrating from 1.7 to 1.9.5. For my part it was in the table options, the values for TASKSERVER_LOCATION or TASKSERVER_REMOTE were wrong, adjusting them then clearing cache corrected the problem. I think by default the search server is on port 8090 but the url your wrote is on port 80.

HTH


#10

The search server is by default set to the same tomcat application which is on port 8080.

If you are in production I highly recommend switching to MySQL anyhow.


#11

I Found the hard coded entry. I changed it to the proper port, and the configuration saved. So now I do not receive any error, but all the searches are coming back no assets found


#12

Clear cache and perform an indexation of all assets.


#13

Where is the Reindex?


#14

Log in with an admin account into the tenant, then click on the username in top right and click on Administration. Then go to Indexing and click “Yes,re-index all files”


#15

Found that and did the reindex. It showed there were multiple items to add.

But when I go back to the search or advanced search it still provides the “no assets found”


#16

The reindex can take several minutes to be performed depending on how many assets you have, check in log file that the reindex is done (or go back to where you clicked on “Yes,re-index all files” it shows how many files are pending reindex).


#17

There are around a dozen files right now. The re-index indicates it has completed.

[//discourse-upload-backup.s3.amazonaws.com/original/1X/f5b8cb9cee5a7ca7b6e2544a5ffe0a7c6469b6fa.png][//discourse-upload-backup.s3.amazonaws.com/original/1X/6cbc3263d7948cbad13fb023e92adc0f9203b009.png]
[//discourse-upload-backup.s3.amazonaws.com/original/1X/4d8fa188c3d44d4fb99599d5ad59d4a2470e5cfc.png]

[//discourse-upload-backup.s3.amazonaws.com/original/1X/51a28d70318f36342d8f1e6399ba3d339bc177cc.png]
[//discourse-upload-backup.s3.amazonaws.com/original/1X/fd0bba86dd04d8ec8e7360bf8e35d298287b50e5.png]


#18

If reindex is done and no error in log (catalina.out) about search server then I have no idea why search is not working :confused:
Have you one tenant or several tenants ?


#19

Single tenant in this configuration.


#20

Out of idea, sorry.