Smart Folders error message

Hi, I’m new to Razuna. I made a new installation 1.9.6, using windows 7 64bit and mysql 5.6.43, Apache Tomcat/8.5.23,java version 1.8.0_201-b09. Everything worked after a few minor problems. I have yet to resolve an abnormal operation on the smart folders. When I create one, an error appears:

Oops, something really strange happened here. Please copy the error message below and send it to your administrator who will help resolve the problem. Thank you.

Badly formatted template: …/…/…/raz2/dam/parsed/c.smart_folders_settings.cfm

Any Suggestion?

Then, I wanted to know if it is possible to directly update a video loaded like mov with an mp4. I’ll explain:

  1. I add a mov video file
  2. I make a convesione with an mp4
  3. I would like the mp4 to be the main video, so that the preview is always visible via web and not downloadable
    I can do this by downloading the new mp4 file and then replacing the mov by making a new upload, but it’s a cumbersome operation, maybe there’s a faster mode?

I just want add that the same problem i have with a fresh installation using Ubuntu 14 LTS.
Mean is a bug.
Waiting for a feedback
Thank you

I got the same error, also [Razuna] 1.9.6, on a Debian 9 machine. The same “oops” message and:
Badly formatted template: …/…/…/raz1/dam/parsed/c.smart_folders_settings.cfm

I looked at that template file c.smart_folders_settings.cfm and found on line 140 what seemed like it could be an extra space between “qry_” and “qrygroup”

<cfset qry_folder_groups = myFusebox.getApplicationData().folders.getfoldergroups(thestruct=attributes, folder_id=attributes.sf_id,qry_ qrygroup=groups) >

Some similar lines have “qrygroup=qry_groups” instead of “qry_ qrygroup=groups”. If I modify the line to:

<cfset qry_folder_groups = myFusebox.getApplicationData().folders.getfoldergroups(thestruct=attributes, folder_id=attributes.sf_id, qrygroup=qry_groups) >

It seems to get further and might be working.
That template file on my install is in: tomcat/webapps/razuna/raz1/dam/parsed