Razuna 1.9.5 error in razuna/global/cfc/db_mysql.cfc


#1

Hi,
There is an error in file razuna/global/cfc/db_mysql.cfc
On line 1477 there is an extra coma at the end of line that causes a mysql error.

Regards.


Unable to install (v1.9.5 on Ubuntu 16.04) - HTTP 500 Error during "Finalize Setup"
New Install using MYSQL setup wizard failure
#2

Hi,

Thank you for the report. I’ve fixed it. However, even with that “coma”,
the installation here worked. What version of MySQL do you have?


#3

Ubuntu 16.04 and Mysql 5.7.20
I don’t know if it’s related but when i try to access “Tenant settings” nothing happens and I got a bluedragon error saying :

The argument THESTRUCT passed to function getdetail() is not of type Struct
Request /admin/index.cfm
File Trace /opt/razuna_tomcat_1_9_5/tomcat/webapps/razuna/admin/index.cfm
|
±- /opt/razuna_tomcat_1_9_5/tomcat/webapps/razuna/global/fusebox5/corefiles/fusebox5.cfm
|
±- /opt/razuna_tomcat_1_9_5/tomcat/webapps/razuna/global/fusebox5/corefiles/Application.cfc
|
±- /opt/razuna_tomcat_1_9_5/tomcat/webapps/razuna/admin/parsed/c.prefs_save.cfm
|
±- /opt/razuna_tomcat_1_9_5/tomcat/webapps/razuna/global/cfc/settings.cfc
|
±- /opt/razuna_tomcat_1_9_5/tomcat/webapps/razuna/global/cfc/hosts.cfc


#4

We use on all our production sites MySQL 5.6.x (MySQL native or Percona). We have not tested with 5.7.x.

That said, have you flushed the template cache?


#5

Well, I should have tried that. It works like a charm after a “flush admin cache”, thank you.

I will let you know if I encounter another Mysql related error with 5.7.