Oops. We can't read that directory!


#1

I installed Razuna and Tomcat as a dedicated service on Server 2008R2.

I have a QNAP NAS with 15TB of data on it. I mapped a network drive to the NAS as Z: and told it to log in using the proper credentials and reconnect at startup. I can see the files there.

I logged into Razuna and went to “Link to Folder” and tried to link it to Z: several times. I reinstalled Razuna. I looked and saw that Razuna runs under LocalSystem. LocalSystem has full rights to Z: but I keep getting the same error. What do I try next?

Thank you in advance.


#2

Hi,

I believe on windows you have to enter a path like “//10.0.0.10/” to the
shared volume (of course with your IP).


#3

I still get the same error. The IP address in my browser just sends you to the web portal where you have to log in. The only way I know to store the credentials is through a mapped network drive. Might it be possible to pay someone to take a look at this for us without the expensive support plan?


#4

Aaron,

Sorry to hear of your issues. Our support plan subscriptions can help in this way. However, I’m afraid that we cannot help you outside of those plans as this would simply be unfair to customers who pay for a support plan.

Maybe someone from the community can help here?


#5

In the services window you will need to change the Tomcat service (and apache if your using it) to use the account that has access to the network volume.

Also you can’t map a drive because drives are only mapped when a user profile is logged into the machine. Instead you will need to use \servername\sharename\ or forward slashes as mentioned above.

This should fix the issue you are experiencing. Had a similar issue.


#6

Okay, so I’ve come back to this project after learning Linux lol. I’ve got Razuna installed on my new Linux box. Same error though. I saw where I’m supposed to change users to run the Tomcat service and even created a tomcat8 user on the QNAP. BUT it looks like for some reason my server is running the service under root. I tried to add root as a user on the QNAP but it is a reserved user name. Any idea?


#7

Ok I mounted a drive using the following:
mount -t cifs -o username=USERNAME,password=PASSWD,vers=1.0 //192.168.1.88/shares /mnt/share

apparently the version has to bet set back to 1.0 or it defaults to a version that QNAP won’t accept. you can close this thread now.


#8

nevermind. it created about 10 thumbnails and then the entire server locked up.


#9

You need to tune your Tomcat server. Once done, it will have enough memory to parse everything.


#10

ok thank you. i just rebooted it and it seems to be going along quickly. i will keep an eye on it.


#11

It’s been up now for 3 days and 18 hours. I’ve been trying to find a way to make sure it’s still syncing. I can see that tomcat8 has a lot of processes running with htop, but I’m wondering if there is a way to see it’s progress? Maybe how many assets it currently has so I can see the number is still going up. Does anyone know if the best way to tell it’s still syncing and perhaps how close it is to being finished?