No assets found in search results

We are trying razuna 1.7 with mysql database.

After uploading some assets, the search result returns a “No assets found!” message. I tried to search by different fields without success.

Scheduled tasks for “index new items” and “rebuild search index” are in place.

Any ideas on how to search assets? Can someone point me on how to debug a search?

Thanks,

Hi Jordi,Are you getting any errors in the logs related to indexing at /tomcat/webapps/razuna/WEB-INF/bluedragon/work/temp/rtelogs? Also please look through some of the threads already addressing this issue for tips.https://forums.razuna.org/topic/search-not-working-27-10-2013https://forums.razuna.org/topic/razuna-search-not-working

BestHarkirat

Hi Harkirat,

Thanks for your reply.

Looks like the scheduled tasks are not running automatically and work when triggered manually.

I have not seen a reference for cron in the manual, but do I need to manually setup a cron?

Thanks,

Hi Jordi, It looks like you bluedragon.xml file might be out of sync with razuna i.e. razuna is trying to call tasks that may no longer exist in the bluedragon.xml file. You can try deleting the tasks and re-adding it and see if that fixes it. Manually setting up a cron job will also work as long as the process is being called.

BestHarkirat

Harkirat,

Thanks for your help, I have recreated the tasks without success.
Can you point me to instructions on how to manually set a cron job?

Thanks

You can schedule the following path to run in crontab which will index all files in all hosts http://localhost:8080/razuna/admin/lucene.cfmYou can try running it manually first to ensure it works.

Instructions to setup a cron job can be found herehttp://www.cyberciti.biz/faq/how-do-i-add-jobs-to-cron-under-linux-or-unix-oses/

Harkirat

Thanks Harkirat,

I think something is wrong in my installation:

Razuna 1.7 standalone using MySQL
java version “1.7.0_65”
OpenJDK Runtime Environment (IcedTea 2.5.3) (7u71-2.5.3-0ubuntu0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)

After reseting the tasks, no tasks related to indexing are shown in webapps/razuna/WEB-INF/bluedragon/work/cfschedule/schedule.log

16/11/14 21:08.21: scheduleTask.run(razscheduleduploadevent[3f06e54c-666e-4ba7-af273e01d428befe]).started
16/11/14 21:08.21: scheduleEngine.run(): null
16/11/14 21:08.42: scheduleEngine started
16/11/14 21:08.43: scheduleEngine: UpdateTask: razfoldersubscribe
16/11/14 21:08.43: taskName=razfoldersubscribe; StartTime=00:01.00; StartDate=11/Nov/2014; EndTime=23:59.00; EndDate=-1; interval=500
16/11/14 21:08.44: scheduleEngine: UpdateTask: razassetexpiry
16/11/14 21:08.44: taskName=razassetexpiry; StartTime=00:01.00; StartDate=11/Nov/2014; EndTime=23:59.00; EndDate=-1; interval=300
16/11/14 21:08.44: scheduleEngine: UpdateTask: razftpnotifications
16/11/14 21:08.44: taskName=razftpnotifications; StartTime=00:01.00; StartDate=11/Nov/2014; EndTime=23:59.00; EndDate=-1; interval=3600
16/11/14 21:08.44: scheduleEngine: UpdateTask: razscheduleduploadevent[3f06e54c-666e-4ba7-af273e01d428befe]
16/11/14 21:08.44: taskName=razscheduleduploadevent[3f06e54c-666e-4ba7-af273e01d428befe]; StartTime=00:00.00; StartDate=16/Nov/2014; EndTime=23:59.00; EndDate=-1; interval=240
16/11/14 21:08.44: scheduleEngine: UpdateTask: razscheduleduploadevent[4d16437a-957f-4888-8659415b94336ae8]
16/11/14 21:08.44: taskName=razscheduleduploadevent[4d16437a-957f-4888-8659415b94336ae8]; StartTime=00:01.00; StartDate=11/Nov/2014; EndTime=23:59.00; EndDate=-1; interval=120
16/11/14 21:08.44: Active Tasks=5; Directory=/opt/tomcat/webapps/razuna/WEB-INF/bluedragon/work/cfschedule
16/11/14 21:09.14: scheduleTask.run(razscheduleduploadevent[4d16437a-957f-4888-8659415b94336ae8]).started
16/11/14 21:09.46: scheduleTask(razscheduleduploadevent[4d16437a-957f-4888-8659415b94336ae8]).exception:Connect Exception: Read timed out
16/11/14 21:11.14: scheduleTask.run(razscheduleduploadevent[4d16437a-957f-4888-8659415b94336ae8]).started
16/11/14 21:11.14: scheduleTask.run(razassetexpiry).started
16/11/14 21:11.15: scheduleTask.run(razscheduleduploadevent[4d16437a-957f-4888-8659415b94336ae8]).finished
16/11/14 21:11.27: scheduleTask.run(razassetexpiry).finished
16/11/14 21:12.14: scheduleTask.run(razscheduleduploadevent[3f06e54c-666e-4ba7-af273e01d428befe]).started
16/11/14 21:12.15: scheduleTask.run(razscheduleduploadevent[3f06e54c-666e-4ba7-af273e01d428befe]).finished

Browsing /razuna/admin/lucene.cmf redirects to :8080/razuna/raz1/dam/index.cfm?fa=c.req_index_update_hosted with a blank page. Nothing gets logged.

Which process should I run in cron in order to perform the indexing?

Thanks

1 Like

You should run this link in your browser to run the indexing process
http://localhost:8080/razuna/admin/lucene.cfm
Substitute localhost with the path to your DAM
When you run it it will return an empty page but it will run the indexing in the backend
After you can run it you can search for something to check if the assets were indexed or not.

Hello, neither of the index or re-index scheduled tasks are running for me, however the script itself at http://localhost:8080/razuna/raz1/dam/index.cfm?fa=c.req_index_update_hosted runs great. I’m on a Windows Server, so I could create a batch file called by a scheduled task, but this gets messy. Is there no way to point the existing scheduled tasks to the script so they work properly? I’ve tried all of the suggestions above, as well as in the linked forum posts above.

I would suggest the following:

  1. Go to the engines backend at
    http://localhost:8080/razuna/bluedragon/administrator (sign in with the
    password “admin”)
  2. In the navigation on top go to “Data &Services” and select “Scheduled
    Tasks”
  3. Delete any tasks that contains the name “razscheduleduploadevent”
  4. Go back to Razuna and delete any scheduled tasks under Administration.
  5. Create a new indexing task that runs every 2 minutes.
  6. Check in the backend admin (item 1 and 2) that the task has been created.

Additionally, on your hard disk go to the temp folder (the folder is
located at /razuna/WEB-INF/bluedragon/work/temp) and check that there is no
.lock file inside this directory (this is a HIDDEN file). If there is one
AND your Razuna server is shutdown remove it.

Hope this helps.

That appears to have done the trick. Thank you!