Multiple values on a custom field

How do we search a customfield for multiple values?
Can we do the following?:
{“custom_fields”:[
{“id”:“8FCDF37F-3CF4-4F90-9F4F7C148F64895B”,“value”:“2255”},
{“id”:“E7D56C3A-916F-4CE3-81E225B2ED93EEBB”,“value”:“Plastic”}
]}

or maybe an andor inside the custom_field property?
{“custom_fields”:[
{“id”:“8FCDF37F-3CF4-4F90-9F4F7C148F64895B”,“value”:“2255”},
{“id”:“E7D56C3A-916F-4CE3-81E225B2ED93EEBB”,“value”:“Plastic”}
],“andor”:“or”}

Thanks,

{“custom_fields”:[
{“id”:“8FCDF37F-3CF4-4F90-9F4F7C148F64895B”,“value”:“2255”},
{“id”:“E7D56C3A-916F-4CE3-81E225B2ED93EEBB”,“value”:“Plastic”}
]}

is correct. andor goes outside of the whole search as you might want to and/or other fields. To search in the same field for several values you either separate them with a space or a comma.

The multiple custom fields with single value using andor does work. However I wanted to search multiple value with the same custom field id. so i tried the comma and space.

I tried the following but got 0 results.
{“custom_fields”:[{“id”:“8FCDF37F-3CF4-4F90-9F4F7C148F64895B”,“value”:“2255,3700”}]}

You can do that in an updated release that will be made public within the coming 24 hours. In addition, you can also use “*” (asterix) for a wildcard search within a custom field. This also works with multiple values.

sounds exciting. looking forward on the updated release.

I just wanted to ask if the hosted service is currently undergoing updates because i’ve been trying to explore the search using custom fields, and i’m not getting the expected results all the time.

e.g. I search “Plastic” and i know that atleast one of my assets have that custom fields value in it. I still get no result found.

also I tested the multiple values in one custom field using comma and space delimiters. im also not getting the expected results.
e.g two assets having different values in their custom fields. so i search both values using comma seperator but get no results found.

one last thing, Im getting the following results in postman.
{
“message”: “arguments.thestruct.on_day doesn’t exist.”,
“errorcode”: “”,
“detail”: “Error at line 1, column 28”
}

I ran the same exact api call with same parameters and value that used to work.

The issue with the missing variable should be resolved now.

Regarding custom fields, we’ve updated the UI for the advanced search with descriptions. Please follow the guidelines there.

NOTE: In order for this to work, we need to update the index in the background! So until the files are re-indexed, the search in the custom fields does not work accordingly.

You can check the status of the re-index under Administration / Indexing.

Got it! I will give it a try.