Link to network folders



Could someone guide me how to configure RAZUNA and Tomcat, so I can link to a network folder like \\server2\home\Archives\images?

I was able to link to a local folder (to where Razuna is installed), following this:

but my requirements involve network linking.



Hi lephleg ,

You can go to Add your files ----> Link to content ----> From Where is you assets store ? —> Choose : Available on my local network.

After that, you enter the absolute path of network folder such as : \ip address\directory name\folder name

Hope this helps.



Dear Huy_Nguyen,

Thanks for your instant reply.

Although I’m able to check the folder and get a success message

Success. The directory can be read and containts 18 files.”,

when I click Establish Link, I get an alert informing me about the linking process and suggests me to reload the folder.
However even after a couple of minutes no assets appear inside the folder. I’ve already tried to reload and rebuild index.

What am I doing wrong?


Okay , maybe there was an error in communicate between razuna and your network drive. So could you please to remove the current connection to your network folder and try to linking to it again to see how.

Hope this helps.



What permissions should be available on the network folder (windows) for the link to be established?

Is there a way to monitor the linking progress through RAZUNA? It doesn’t seem to appear in Log…


To allow Razuna can connect to your network drive , at least this folder have : Read/Write permission , to allow read and save the assets to this folder. Razuna not monitor the linking progress as the connection is out of Razuna elements.



I’ll request these permissions from my admin and I’m gonna get back to you soon.

Thanks a lot for the support!


Dear Huy_Nguyen,

I successfully managed to link the folder now.

Thanks again!


Hi there, I’m trying to test out the ‘link to content’ functionality, but am having no luck with this. I’m running Razuna 1.8.2 on Linux. I’ve tried using the steps listed in this thread, but no matter what I do I receive the error “Oops. We can’t read the provided file!”

I’ve tried using the following formats:


For the purposes of testing, I’ve shared a folder from two different Windows systems with full read/write permissions for everyone. The documentation is almost non-existent in regards to the Link to Content functionality and does not specify how to format the network address for local network content or how to handle permissions or to specify an account to use.

I have confirmed that I can ping the network locations from the Razuna server with no problems, so it should be accessible over the network. There are no firewalls in place between these systems.

Please assist!


Hi ddog800 ,

Please check this link for your reference :

From this we were show how to link to content and how to fill in the local address path .

Hope this helps.



Hi there! Thanks for the reply. I’ve actually looked at this page already, but it doesn’t seem to have the info I need for a network location. I’m needing to link to network content using the option “Available on my local network”, but I’m not certain how to format the network path. Do I need to first mount the network location into the local file system from the shell or is Razuna able to use a direct network path (like smb://server/share)?


Nowhere do we say that Razuna supports smb. Simply mount the volume and
then you can link your files with an absolute path.


Gotcha, that makes sense. I just wasn’t clear if I needed to handle the mounting process myself, so that should work nicely.

Thanks for your help!