ImageMagick version


#1

Hi

I am running the version 1.9.1 on Windows Server 2012 R2 and I have installed the ImageMagick-7.0.5-10-Q16-x86-dll.exe (https://www.imagemagick.org/download/binaries/ImageMagick-7.0.5-10-Q16-x86-dll.exe). However it says that the executable cannot be found. I think it’s looking for “convert.exe” which no longer exists. Renaming “magick.exe” to “convert.exe” got around the issue but when I upload images it fails to crop.

Thanks,
Sam


#2

Yeah, simple solution is to use a version 6.x of ImageMagick…


#3

The v7.x installer wizard has an option in Select Additional Tasks where you can “Install legacy utilities (e.g. convert)”. This may be the work-around to allow the latest releases to work with Razuna. (Just noticed this, haven’t tested yet.)


#4

Yes, you need the legacy setup. We are looking for convert, etc. The v7.x
are all one command and is not supported.


#5

So, would you say that ImageMagick-6.9.9-13-Q16-x86-dll.exe (Win32 binary, 16 Bits/pixel, Dynamic) would be the most recent version that is supported by Razuna? I found it in the FTP archive located here.


#6

Yep, or installing the legacy options as you outlined in your original post


#8

the solution is simple. on ImageMagick-7 static folder. copy and paste the magick.exe and rename de new magick.exe copy to covert.exe.
important!!! add the folder to the system path.


#9

The solution is to install the legacy executables!

Razuna needs more than just the convert one.


#10

You are correct. thanks