Faster way to delete old backups from Admin?


#1

Is there a faster method of deleting multiple backups without having to go through the admin interface? For some reason, our install of Razuna decided to make duplicate backups, so instead of one per day, we now have two per day. And now we have accumulated over two years of backups. I am trying to get a handle on the situation and pare it down, but sitting there and clicking Remove and then waiting a few seconds adds up, especially if there’s over 700 backups to go through. Is there a query that I can use which would delete all of the old backups up to a certain day?

I’m assuming this extra weight is what ballooned our backup/restore H2 export to ~20 GB in size. I’m trying to get us over to version 1.8.2 (from 1.6.5!) as quickly as possible, but the bulk is delaying our efforts.

Thanks,
Will

Also, side question: is there a way to limit the number of backups, say a setting that only preserves only the recent X number of backups, and automatically deletes the older?


#2

Will,

If you want to remove all backups, you can shut down the Razuna server,
then navigate to the folder razuna/admin/backup and remove all files in
there. Now restart Razuna again and they are gone.

Regarding backups we highly recommend to use an external tool to backup
your data and not use the internal one. Also, I highly recommend to switch
to MySQL!


#3

Yep, worked perfectly. Once the 20 GB H2 file was gone, I could do a proper backup and use those files on my new install (upgrade). We’re also using a proper backup solution on all of our servers now, so I’m switching off that option as you suggested.

Done. I set up a new install with Java 1.8.0_91 and Apache Tomcat 8.0.35 (x64 version, Windows service). Downloaded the latest Razuna and Razuna-searchserver files from GitHub, installed those. Went through the setup wizard and set everything up as a new install with the intention of copying/restoring the backup from the current server (still running version 1.6.5!). The only hitch I ran into was the MySQL database set-up: it doesn’t like it when you use a database name (or user) other than ‘razuna’ – I kept getting #1146 errors (e.g., Table ‘razunaDAM.hosts’ doesn’t exist) on my MariaDB 10.1 server. Once I set everything up EXACTLY as instructed, with no deviation from database name (“razuna”), user name (“razuna”), and collation/character set (“utf8” – our server default is utf8mb4), it ran smoothly. Note: That was a little bothersome because we have a system for how we create database and user names here at work, but I am not going to worry about it. Once it was up and running, I was able to do a successful import/restore of the current server’s database (including the database update) and everything is looking good so far while we are testing out 1.8.2.

Thanks for your help!


#4

Thank you for the feedback. Actually you should be able to change the
database schema and name, others are doing that too. In nay case, happy to
see that you got it working.


#5

Hi there, I’m trying to downsize our Razuna data - currently 158GB - I deleted about 6-8GB so far but no sign of “shrinkage”… Checked the Trash folder and deleted everything there as well.Still no downsize. Not sure why but maybe there is a master backup somewhere that I could delete as well? or old backups which are in the way? would you know where I should look, what I could do?


#6

Hi Studio_Studio ,

The backup files of Razuna are listed from Admin Backend. You can login to Admin backend module for checking it.

Hope this helps.

Thanks