Error on file browser stuck on loading


#1

Hello,
i have done a migration from old razuna istance 1.8 to last 1.9.5.
I have followed migration tips on wiki. I have done a backup(h2) on old instance, create a new one and after imported backup, and i have done “update database” request.
After this every time in file browser i see a “Loading…” loop. After checking http request i see that there’s one refered to folderlist:
http://***:8080/razuna/raz1/dam/index.cfm?fa=c.getfolderfortree&col=F&id=%23
and the reply
We are so sorry. Something went wrong. We saved the error and you or your administrator can notify us of this error within the Administration.

I have tried to flush all caches : Administrator, template and others but nothing to do…

here the bluedragon error dump:

bluedragon.log report:
11/03/18 15:06.21: Table ‘razuna.itb’ doesn’t exist
11/03/18 15:06.21: RTE: /usr/share/tomcat/webapps/razuna/WEB-INF/bluedragon/work/temp/rtelogs/bderror-2018-03-11-150621_617623943892932347.html

Update.:
i have done a mysql queries log, this is the query from getfolderstree
https://pastebin.com/sPHV22S6
i have tried to execute on mysql and work fine… so where is the problem?


#2

Flush the database cache and foremost the template cache.


#3

I have done this… but not work… :frowning:
i have done an “admin cache flush” , “database cache flush” , “template cache flush”
but nothing.


#4

At the end i’ve done an import on 1.8 version. Updated to the 1.8.6 (all works) and after to the 1.9.1.
I have done flushing… and other things after upgrade. All works fine but there’s a problem on showing content of folders.
I have done some test and at last i found a solution in a fix on 1.9.5 (https://github.com/razuna/razuna/commit/916fd09207defa166c91a261e55a266c43778178) that add a groupby on a addCustomFieldsToQuery that, without this, return a field in binary and has broken Razuna. After this fix all works fine…
So i decide to upgrade to 1.9.5. After import i have done ALL CACHE FLUSH, but i receive a “Loading…” on folder tree with the same error log of previous one post.

Any ideas?


#5

I have the same problem after a fresh mysql setup.

The same setup with the H2 database works fine.


#6

Changing from XAMPP mysql (mariaDB) to mysql 5.7 solve the problem.

Thx


#7

I’m on MariaDb 10.3.5 i can’t switch to MySql 5.7.

it’s possible to isolate bug/compatibility problem ?


#8

If you have a support contract with us we can look into it. Otherwise, not
really.