Create custom field not working


#1

Hi all,

on my new Installation i cant create a new custom field.

i filled out and select add, but thats it. i cant see it over the “add new custon field” Box and its not under descripion & keywords in the Metadata tab.

The same problem is in the Razuna Docker image.

Thanks


#2

Can you please do a step-by-step description here so we can try to
replicate it. Furthermore, please provide Razuna version, database in use,
OS and browser version, etc.


#3

Hi Nitai,

OK, this is my Installation:

Installing the Server with Ubuntu 16.04 and all Updates. I take a look in the Installation manual from wiki.razuna.com an d do a step by step installation from the system.

All points in the installation instructions up to ffmpeg made no problems.
Ffmpeg had an error in the compiling com source code.
After the installation I called the site and finished the setup.
In razuna admin I created a new host and announced me there.

Which I in the administration on custom fields to create a new one comes only once briefly the progress bar, that’s it.

The fields appear nowhere.

My system:

Windows 10
Chrome version 56.0.2924.87 (64-bit)

But also in the edge and firefox is no change.

Even in the docker container with the version 1.8 contained in it, the same problem exists.


#4

OK i see the problem is in my generated tendents. in the demo tendent works fine.

what is this ???


#5

Hi Joerg_Grabitzky ,

Please try in Demo tenant first then recreate a new tenant to see how from your site.

Hope this helps.

Thanks


#6

Hi Huy_Nguyen

i think i have the problem. i generate new host with german as only language.

New field noes not appear. Enable english in the setting, that i have 2 language, all works fine.


#7

Okay , so the new field appearing when you enable the English language. Does it works fine now with new field ?


#8

Yes, only then enable english and german. Only german language do not work.


#9

Okay , Thanks for your information. Its very helpful.


#10

Problem still exists in Version 1.9

I have installed Razuna and added some custom fields. They did work fine.

Then i have added GERMAN language and logged off and on. Now the custom fields have dissapeared on the front end.

If i go into administration, i can still see the fields. But if i edit them, i can see the problem: the German translation is missing! And the real problem is that there is no text field to enter the german translation!

If i add a new custom field, i get a textfield to enter the translation. But this field does not show up with already existing fields.

Now i have to delete my custom fields and recreate them while german language is activated.


#11

Ok, i now have deselected english language, now it is not possible to add a new custom field to the database. You can fill in the form as normal, but when you press “Hinzufügen” [add] nothing happens.

I assume that it will not be saved, as the english ID-Field is not filled in. This field is not displayed any longer as i have switched of english language.

-> english ID-Field has to be displayed at any time
-> other fields for translation have to be display in order of the selected languages
-> if there is no translation then the english ID-Field has to be used as a fall back


#12

Now this is getting nasty.

I have added my custom fields after i have added german language so that the fields have proper names für each language. And i have english and german language activated.

Now, if i use english language everything Looks fine:
CustomField_english


But if i use german language this Radio button gets 16 additional copies:

As you can see by the value, only the last one is the correct one!