Can't Import LDAP Users


#1

Created a new 1.8.6 server and configured LDAP authentication. Was able to Import some users a few days ago but, now when I try to import users nothing happens at all. Checked the logs and its reporting: Query Error: NULL not allowed for column “USER_PASS”.

Being curious, I set up a completely new instance of razuna and it gave me the same results. Tried different usres, different domain controllers and different browsers. Is there something I’m missing or something I messed up?


#2

Hi Joseph_Guerra,

LDAP is quite specific to every organization. As we have many customers
using it, we know that it works.

Check on wiki.razuna.com and on this forum for further help.

May I know about the OS? and Java version? … Please try to clear the web cookies and template cache from Razuna then try again.


#3

Hi, this is on a RHEL 7 server and the java version is openjdk v.1.8.0_101

Clearing the cache and the cookies did not help.


#4

Not sure what happening from your site , as you described that you were able to import users few days ago but then can not do it.

Please try to re-config the LDAP Server Details to see how.


#5

I have the exact same issue.

Please note the “AD Server Users List” pop-up page works and is fully populated.

When a user is selected for import and “Save” is pressed:

  • no error message appears on the screen.
  • the user is not imported
  • the error log shows the NULL not allowed for user password sql error described in the previous comments.

Please note: I’ve been monitoring my host’s network connection for ldap transactions and see the queries that generate the “AD Server Users List” dialog. No further queries are produced when attempting to import a user.

This appears to be a database not LDAP error to me. We are still in evaluation and are using the embedded H2 database. We’re using razuna version 1.8.6.


#6

Can you please switch to MySQL and see if the issue persist? H2 shouldn’t
be used (in our case) for production. Thank you.


#7

Identical configuration that fails with H2 works with MySQL.

Thanks,
Michael


#8

I’d like to add that I just ran into this exact same problem while I was working on getting the system up. Once I switched over to MySQL, the problem disappeared and I can now import LDAP users. Looks like it’s a problem with the H2 db.


#9

Hi ddog800,

I have run into same issue, can you tell me where to configure mysql settings instead of embedded DB?
I hv mysql DB up and running.

Regards,
Vinay


#10

Okay got this done via custom installation at console startup.

TY


#11

I am having this same problem. I was on the embedded database and just moved to MySQL (restoring from backup). I’m still getting the error: “Query Error: NULL not allowed for column “USER_PASS”;”

We are on Razuna 1.9


#12

I suggest to reimport your users again and see if that fixes it. The issue is that the password column value is not passed in.


#13

We tried changing DBs to MySQL, which didn’t fix the problem. We tried to delete users and re-import them, which did not work. I finally did a fresh install with MySQL (without ever touching the original embedded DB), and we’re good on LDAP now. Thanks!