API http instead of https


#1

Hi,
I was testing version 1.9.5 with http and all was good.
I changed Tomcat configuration to use https on 8443 port, I can access razuna and all is fine.
But when I call API like searchassets, the asset url in the response are in form http://myserver.mydomain:8443//razuna/assets/ instead of https://myserver.mydomain:8443//razuna/assets/

Am I missing a parameter in Tomcat or in Razuna to tell to use https and not http ?

Thank you.


Razuna 1.9.5 API - search asset, maxrows returns twice rows
#2

Hi,
In the file tomcat/webapps/razuna/global/cfc/settings.cfc at line 1419
there is :

<cfset application.razuna.api.thehttp = “http://”>

Il I replace that with :

    <cfif cgi.https EQ "on" OR cgi.http_x_https EQ "on" OR cgi.http_x_forwarded_proto EQ "https">
            <cfset application.razuna.api.thehttp = "https://">
    <cfelse>
            <cfset application.razuna.api.thehttp = "http://">
    </cfif>

it works like a charm.

Regards.


#3

True this works. However, we already set this application wide, hence this code is a leftover.

However, good catch. Thank you.

That’s why open source works :slight_smile: